Sent Email to @Hotmail/Outlook.com get's rejected
Incident Report for Rich Keller Editor and Email
Postmortem

Hotmail/Outlook servers were blocking ip used by internal email provider causing legit email sent to email accounts using exchange/hotmail/outlook.com to be bounced.

Identified as a false positive. IP reputation restored. Will continue monitoring.

Posted Oct 22, 2022 - 01:15 CDT

Resolved
This incident has been resolved.
Posted Oct 22, 2022 - 01:11 CDT
Monitoring
A fix has been placed, and monitoring for deliverability.
Posted Oct 22, 2022 - 01:08 CDT
Identified
Hotmail/Outlook Server is blocking email due to false positives on their side, steps have been taken to lift false positive blocking. Use an alternate sending address in meantime.
Posted Oct 21, 2022 - 18:28 CDT
This incident affected: Email.