Email sent to hotmail/outlook.com related servers being delayed, bounced or blocked.
Incident Report for Rich Keller Editor and Email
Resolved
Email deliverability is back to normal when sending to Hotmail/Outlook/365, Continuing to monitor.
Posted Oct 31, 2022 - 12:41 CDT
Update
We are continuing to monitor for any further issues.
Posted Oct 23, 2022 - 16:45 CDT
Monitoring
Known issue with sending email to Hotmail/outlook/exchange email addresses. The issue is ongoing, and steps have been taken to mitigate it.

No ETA.

Please use an alternate sending email address to reach outlook related recipients. Not sure if this issue affects your sent email? You will receive a bounce message, and a telltale sign is the bounce message is produced from a "somthing.something.outlook.com" server.
Posted Oct 23, 2022 - 16:44 CDT
This incident affected: Email.